qte5 0.0.7

The minimum wrapper of Qt-5 for D


To use this package, put the following dependency into your project's dependencies section:

dub.json
dub.sdl

QtE5 - is a D wrapper for Qt-5 graphics library.

logo

This is a small study library to work with GUI Qt-5. It is used for dynamic linking and easy in use on Windows 32/64 and Linux 32/64.

This short video about qte5 and ide5 [https://www.youtube.com/watch?v=DuOl-4g117E](https://www.youtube.com/watch?v=DuOl-4g117E)

Slots and signals in QtE5 http://lhs-blog.info/programming/dlang/slotyi-i-signalyi-v-qte5/

QtE5 - uses the following libraries depending from OS

QtE5Widgets32.dll     --->  Windows 32<br>
QtE5Widgets64.dll     --->  Windows 64<br>
libQtE5Widgets32.so   --->  Linux   32<br>
libQtE5Widgets64.so   --->  Linux   64<br>

<p>The most actual version for Windows 32 (QtE5Widgets32.dll) as on it the basic working out and testing is conducted.</p>

For example forth language:

console5_forthd -i test.f

Install for Windows 32:

Copy all files from RunTime-Qt-5\rt_Qt5_windows32.zip in root folder. 

##Screenshot screen screen screen

Authors: MGW <mgw@yandex.ru> Mohov Gennady Vladimirovich

Dependencies: none

Versions:
0.0.7 2016-Oct-08
Show all 1 versions
Stats:
  • 0 downloads today

  • 0 downloads this week

  • 6 downloads this month

  • 63 downloads total