dray 4.0.0-r1

raylib bindings for dlang


To use this package, run the following command in your project's root directory:

Manual usage
Put the following dependency into your project's dependences section:

DUB Package

dray

dlang bindings to raylib v3.5.0 (based on the official upstream 3.5.0 release).

some minor changes are included:

  • raygui included
  • HIDPI enabled

usage

all you need to do is add this package as a dependency and it should automatically build the Raylib C library and link it in. if for some reason you want to use a custom build, just place your own libraylib.a in the package root (usually something like ~/.dub/packages/dray_xxx.

note that raylib has some of its own dependencies such as OpenGL.

example

see example, which demonstrates a simple application using these Raylib bindings.

Authors:
  • xdrie
Dependencies:
fluent-asserts
Versions:
4.0.0-r3 2021-Nov-25
4.0.0-r2 2021-Nov-25
4.0.0-r1 2021-Nov-24
3.5.0-r4 2021-Mar-15
3.5.0-r3 2021-Mar-15
Show all 14 versions
Download Stats:
  • 0 downloads today

  • 5 downloads this week

  • 13 downloads this month

  • 350 downloads total

Score:
0.0
Short URL:
dray.dub.pm