Description

OOP wrapper for librdkafka

Package Information

Version0.2.0 (2017-Mar-28)
Repository https://github.com/tamediadigital/librdkafka-d
LicenseBSL-1.0
CopyrightCopyright © 2016, Tamedia AG
AuthorsIlya Yaroshenko (Converted from the CPP wrapper)
Registered byyawniek
Dependencies

librdkafka

Installation

To use this package, put the following dependency into your project's dependencies section:

dub.json
dub.sdl

Readme

librdkafka-d

Object oriented wrapper on top of librdkafka.

vibe.d

The wrapper does not depend on vibe.d but supports its event based engine. To add vibe.d support add --combined flag to the dub command line (dub --combined) when you build your project.

Available versions

0.2.0 0.0.1 ~master